Friday, April 20, 2007

Getting it not so right

I needed to install a new server, and having thus far run Mandriva on my servers, I stick with it, Mandriva 2007 in this instance. During the install process I get all excited when I see a big splash saying easy to use great system and network backup software free in this edition for upto 50GB of data. I install the server OS, wrestle with upgrades and dependencies for my other applications, finally get everything how i want and need, and then decide, OK time to see how good this new backup thingy is that the Mandriva Install screen was raving about. So I install it, doesnt complain, all looks good, check with the CLI, going well and executable exists, daemon loads and then install the GUI (which is the big rave since its the bees knees, not the usual CLI stuff). I install the GUI package, all is well, and then execute. Bang! Mandriva tells me sorry mate, the Java package you have installed is not compatible with the application you are running. OK, no problem, I install other Java packages, try again, nope, same old same old. Trawl the web and find out that the Mandriva Java package is different from the Sun one and not 100% compatible. Find a sun-compat package, but only for 2006, none for 2007. Do test install and structure is different so no go. So I sit back stare at the command prompt for a while and ask the question, if you know you don't have the necessary and right dependencies/packages to make this work, why rave about it during the install process, and advertise it so loud and clear? Sometimes its things like this that make one lament at good old Windows (shudder?! but I liked NT4) and about Ubuntu and other Linux Distros (which no doubt will have their own set of drama, but that is another story). (sigh!)

Obviously the command prompt said nothing just sat and blinked at me. I am pretty certain I saw a smirk in the blink too......

No comments: